2.1.1 won't edit large document


after updating to FoldingText 2.1.1 I can’t edit a large document (30217 Words) any more. (Some other, smaller documents didn’t seem to cause problems.)
Placing the cursor at the end of a paragraph and typing will not show / append any characters. When I then place the cursor inside that paragraph, the previously appended letters appear – but only for as long as the curser stays inside of the paragraph, they get hidden again when the cursor leaves the paragraph. This is independent of the “Hide Syntax” setting.
Even more: Inserting text inside a paragraph seems to work, but when the cursor then leaves the paragraph, the latter’s view gets truncated: If I inserted 6 characters into the paragraph, the last 6 characters will be hidden as soon as the cursor leaves the paragraph.
Also, this is not only a problem of visibility, but the save command won’t change the file at all, no changes get saved to the file.
Deleting and re-installing 2.1.1 from the App Store didn’t help.
I now returned to version 2.1 from a TimeMachine Backup, which works fine with the same document.

Same here with a 1500 words file.
I first thought it might be a matter of plug-ins or that I’ve went too far into theming, but even with plug-ins removed and theme reverted to default, it won’t work.

I was hoping for a fix with the next release but it is still the same with 2.1.2.

The worst thing is that sometimes it will work, but sometimes it won’t, with the same file.

@isg, can you confirm you still have that bug using 2.1.2 ?


Hmm, this is weird. Do you guys have a file that you can share with me that exhibits this behavior? Or is it consistent with all large files?


Ouvert sans aucun problème un vieux texte de 500 613 mots (ouupsss… words) avec cette 2.1.2, ajouté quelques ¶ pour voir, enregistré le tout et ça tourne…

I can confirm the problem persists with version 2.1.2 and has been introduced with 2.1.1.
The answers so far suggest that the file size is not the determinant factor. I don’t have a second file of that size to test and so far have experienced this behavior only with this single document.

I don’t want to post my document on a forum, but I can mail it to an official support e-mail address for testing purposes, if you provide me with an address and maybe a subject to use.

Out of interest, do you have any text in this FT doc that you’ve copied over from an external file? I’ve noticed some of the issues that have been listed in this thread (save command won’t work, no changes are saved, some text is truncated… also for me, tags aren’t highlighted). I think my problem was down to some confused CR/LF mix-up in copied text. May not be the same issue you’re facing, but just offering an option…

The document has, as far as I can remember, been written from scratch using FoldingText.
But I’ve just checked the line breaks: All were LF only (Unix). Also, I made a copy of the file and converted any line breaks zu CRLF – not a change in behaviour!

BTW: just like macIm noticed, the fault does not always occur: Sometimes, after restarting FoldingText and reopening the file, it works normally, but in the vast majority of cases it doesn’t.

I’ve now rendered the original document illegible by replacing letters. It still causes the same behaviour of FoldingText, so I uploaded it for testing purposes:

FoldingTextBug.md (229.4 KB)

I updated to 2.1.2 (today); now experiencing more issues with my main file. I’ll post my own findings separately in case it’s a different issue, but symptoms do sound very similar. #sadface

EDIT: Posted here: http://support.foldingtext.com/t/2-1-2-bug-issues-editing-updating-document/1530

If anyone in this thread has a moment to take a look and corroborate whether the issues I’m seeing match with yours, I’d appreciate it. Thanks.

hey @isg,

Not sure what’s going on at the moment. Foldingtext seems to work fine for me. I’m on OS X 10.11.3 (15D21), FT 2.1.2, and your file seems to be working. I tried editing a few lines here and there, but still works :confused:.

Are there a series of steps that I can take to reproduce the issue?


Actually, I just found out I can’t reproduce it (using FoldingText 2.1.2) on both of my Macs at home, neither an old 2007 MacBook C2D, nor a last year’s iMac 5k (Core i7), while the problem still occurs on my iMac at the office (don’t know the generation exactly, but it should be about two years old, still normal resolution, Core i5). Haven’t quite figured out any differences in setup yet. (But I’m pretty sure, the problem had also occurred on my home iMac with FoldingText 2.1.1 before I opened this topic :-/)

Back at the office, based on yesterday’s findings, I just tried to reset my local FoldingText installation by deleting the ~/Library/Containers/com.foldingtext.FoldingText folder (before launching FoldingText).

That seems to have done it, I haven’t been able to reproduce the problem, neither with the test document nor with the original. FoldingText seems to be working fine again.

Dear all,

    1. I’ve FT 2.1.2 on Yosemite and FT with my large ToDo file (about 17 k words) exhibits the same kind of weird behaviors than those described above: text cannot be written anymore, save doesn’t work, etc. I tried to delete the folder isg told us, without success: same behavior afterwards.
      thx !

Me again,
FT is completely useless: I instead use TextEdit to edit my todo list.
It’s a shame!
please investigate this bug!


I am facing the same problem (~8k words) and have tried the workaround but not luck. I can consistently reproduce it. I am using FT 2.2 768. @mutahhir How can I help you debug the problem?

Thank you,

Hi Parag,

Thanks for wiring in. The biggest problem with being able to resolve the bug is to reproduce it. If you can send me the smallest file possible that is reproducing this reliably, or give me a detailed list of steps that I can use to reproduce the issue here, that would really help. Also privately messaging me the crash log will also help, but being able to reproduce this issue is the most important.