Bug in FoldingText 2.2

Hi, i like to work with folding text.
Unfortunately , when the text becomes a little more complex, I can not edit the text any more.
Either the complete text disappears or the current input does not appear and the document can not be saved.
I Have a short Example File, which i can upload, if there is a possibility to upload a file.

I tried to copy the complete text from Textwrangler in a new FoldingText Document.
It works …

What is the Problem?

best regards

… Christoph

hi wesc,
seems to be the same problem as this described in a past thread: http://support.foldingtext.com/t/2-1-1-wont-edit-large-document/1394/13
seems to be a transient problem. I’ve been experiencing it for a couple of weeks… and my FT version (2-1-2) works again, without any changes…

Hey wesc— this forum does allow you to upload. Hit the icon with the upward pointing arrow (next to the bulleted list icon) when writing a message. I’d be interested in seeing your example; as Dessus_Ph suggested, it’s a problem that a few of us seem to share, and for many of us, it seems to come and go, but we haven’t yet pinned down the cause.

Out of interest, are you working with Folding Text on a laptop or desktop machine?


thanks for the hint.
I uploaded a simple Example.
If I edit the text after “eruiert werden.” (second bullet) nothing happens.
The file was not saved and you don’t see your input.
If a copy the whole text in a new file, everything is fine …

I work on an laptop (MacBook Pro 15 Mid 2012, Intel Core i7 2,6 GHz 16GB El Capitan 10.11.3).

best regards
… Christoph

TestBug.ft (1.6 KB)

Just opened and edited— no immediate issues that I can see. At first look, the file itself doesn’t seem to be a problem…

Thanks for trying …
mysteriously …

I sympathise— this is pretty much what I experience every now and then, but I don’t think anyone’s been able to track down the trigger yet. I just followed the steps I could see you taking in the gif, and it doesn’t trigger the bug…

Have you looked at console.app when things go wrong?

Hi @wesc,

I’m sorry you’re experiencing issues. I’d love to get this sorted out if only I can get to the bottom of it.

With regards to your document and gif. Thanks! However, I tried to follow you in the gif and found something strange in the very start. I don’t understand how the first line ‘ewewew’ is so far to the left. I think that’s where the problem started. What operation did you do to make that new line?


I am a little perplexed.
I just tried to repeat the example; This time everything works.
In next occurrence I will inform you again.
Thank you very much.

@Mutahhir, When entering I had made simple returns.

best regards
… Christoph