Computer Restart "Clears" Document

When I restart my Mac (MacBook Air OS X 10.8.5) and FoldingText is running, the documents I had open at the time open as blanks. If I close them and reopen the text comes back, but still somewhat disturbing.

Are you seeing this with all documents?

There’s a known bug where this can happen, but only with the built in help documents:

  • Help > User’s Guide
  • Help > Node Path’s Guide
  • etc…

And only when you open those documents and don’t edit them. It should be, at least in my testing from a few minutes ago, that FoldingText will properly reload any of your own (or any edited) document correctly.

Definitely seeing this with all documents. If you’re not seeing it, the OS version may be the issue?

Hum… I would guess so. Is anyone else seeing this on 10.9?

Yup, on OS X 10.9.3. When FoldingText restarts after a reboot or logout/login, it reloads the documents that were open when it was closed, but they are blank. If you then manually close and re-open them, the contents are there. I’ve got used to it.

Odd, I wonder why I’m not seeing this.

Here are the exact steps I’m performing:

  1. Open FoldingText
  2. Create new document
  3. Type “Save me!” into document
  4. Restart

Do you see the problem after those steps? If so can you try removing all plugins… still see the problem? Also in the general pane of system preferences do you have either of the “Ask to keep changes” or the “Close window when quitting” checkboxes selected?

I just did about 10 reboots to see if I can produce this with a new document. So far:

  • not saved: comes back ok
  • saved in ~: ok
  • add .todo: ok
  • make the file a couple of paragraphs: ok
  • move the file to Documents: doesn’t come back at all after reboot or rather it appears for a second and then disappears

Maybe something to do with subdirectories?

This just happened to me with documents that were open in FoldingText but not saved. I had about 8 of them open with content in each, and after my computer rebooted due to a dying battery, all content in each of the articles are gone.

What’s strange is that I’ve quit and reopened FoldingText in the past and all of these documents were preserved correctly.

Interestingly, one of the documents isn’t even editable - nothing happens when I click inside, and does not display the “0 words” at the bottom left.

Any way to restore them? I’m pretty disappointed that all the content has been lost.

I’m on a Mac running 10.9.4.

Can you browse back through previous versions using Time Machine?

Just to flag— this is still an issue for me. Currently on Yosemite Beta 5. Issue as originally reported: on restart, FoldingText reopens any documents that were open before restarting, but the documents are empty until closed and reopened.

I’ve gotten used to it, up until the point where I recently lost the contents of a couple of documents I hadn’t manually saved. My fault, true, but it would be nice to know whether this bug has been trapped…

Also: obvious, but hadn’t occurred to me— if you enter any new text into the “empty” document, you lose anything that was supposed to be there prior to. This got me when I restarted, didn’t check FoldingText first, and clipped a task from email via a plugin. Tabbed to FoldingText, realised what happened and retrieved an older version of the document via Dropbox, but still experienced that nervous twitch of “where’s all my stuff gone???”

This happens with me too. If you close the documents and reopen the text is back, but it’s a bit scary when, for instance, your main Personal Kanban document containing all of your projects comes up blank.

@mark Is this still happening for you in the latest OS X 10.10.1?

I’ve just been trying to reproduce this again, but still am not having any luck. I’ve tried all the combinations that I can think of. If you are still seeing this problem can you give me exact steps to reproduce on OS X 10.10.1?


Still an issue for me FWIW. When I shut down FT with one file open, reopening FT loads a new, empty, unnamed file. If I shut down my computer with files open, FT will restart with those files, but each file will seem to be empty (just tested).

@JSLR Thanks for your continued help with this. But I’m afraid I still have more question, I still can’t reproduce this.

  1. What are your settings for System Preferences > General:

    • Ask to keep changes when closing documents
    • Close windows when quitting an app
  2. Can you recreate the problem by logging out instead of doing a full restart? (full restart takes much more time for me to cycle through when trying to recreate problem under different situations)

  3. Do you have any plugins installed? If so can you see if you can reproduce this after removing all plugins?

  4. Where are the effected files being saved? Can you make sure that iCloud is out of the equation (i.e. just save to your desktop) and see if you can still reproduce the problem with those files?

I’d really like to solve this issue, but as of yet I haven’t been able to reproduce it, and I won’t be able to solve unless I can reproduce. Thanks again for your help.

Still happening for me BTW. Brand new Macbook Pro, pretty close to default settings. No iCloud involved.

Hey Jesse— I’ll try to have a look at these this weekend and come back to you…

Thanks, any luck? I still can’t reproduce it.


Reasonably new MacBook Air running most recent version of Yosemite here. Having the same issue.

Preferences as follows:
Happens when “close windows when quitting” is checked and unchecked. “Ask to keep changes” is unchecked for me.
Logging out and logging back in does not cause it to happen.
No plugins installed.
For me, the affected files aren’t getting saved at all – I run into this problem when I reboot my machine with unsaved documents in FoldingText. They’re not in iCloud, or…anywhere, it seems.

Edit (12/10 10:16 PST): Okay, this is officially frakking bizarre. Checked “ask to keep changes,” hit the CMD-CTRL-Power shortcut and caused a hard reboot (which shouldn’t happen). Document reloaded fine. Tried another restart with the same shortcut, again, hard reboot. Rebooted again from the Apple menu, everything comes back fine – again – but when I looked at system preferences, “ask to keep changes” is unchecked.

But it seems like the problem is fixed? I have no idea what’s going on.

Edit 2 (12/10 10:21 PST): I’ll say with about 80 percent confidence that it’s fixed. I’ll keep an eye on it.

Hey Jesse— I’ve been trying to reproduce this over the past couple of days (apologies for the delay). I’ve tried logging out vs restarting, and different combinations of “ask to keep changes…” / “close windows when quitting”. You may be happy to hear that I’m no longer seeing the error. Not sure what happened— maybe an OS X update since the last time I saw it happen?

Obviously, I’ll flag it up if I see it happen again, but for now, it looks like this one is no longer an issue.

Hate to say it, but… it happened again. I haven’t changed anything with my settings. Had a .taskpaper file open, computer shut down after installation of a new graphics driver (Duet Display app) and on restart, FoldingText opened with a window for the document I was working on, but no text in the document.

I can’t figure out what the trigger is. I’ve had a problem with Safari today, and I’ve been restarting repeatedly. Haven’t experienced the issue up until this point, and I can’t figure out what’s changed that would have an impact. Window was in full-screen mode on shutdown/restart, but that’s how it was for all the other restarts. Hm.

OS X 10.10.1
FoldingText 2.1 Dev 741
Ask to keep changes when closing documents (yes)
Close windows when quitting an app (no)
File affected is in a Dropbox folder.
Plugins— I have a fair number of plugins installed. Haven’t gone as far as removing all of them to see whether I can reproduce the problem.

Again, will keep you updated if there’s anything further I can determine.