Copy text not working

I found a previous topic about this, but no resolution. Anyway, I’m finding that I am unable to do a normal “Copy” from within FoldingText. Using either Copy from the File menu or the keyboard shortcut does not work - nothing gets saved to the clipboard, and I get the following message in System.log:

5/2/15 6:46:25.783 PM FoldingText[42869]: Can't allocate a new block for a pasteboard. Creation of a new Pasteboard will fail.

The copy as HTML or copy as rich text options do work properly.

I’ve tried relaunching the app, and I do not have any plugins installed. This is on OS 10.10.3, FoldingText 2.0.2.

Thanks for the system log info. I did a google search of that log and this issue seems to be showing up in a number of apps that use a webview, so I don’t think the problem is FoldingText specific. It also doesn’t effect everyone, copy/paste is working fine for me on 10.10.3. Few things to try:

  1. Does the problem happen if you run FoldingText from your Guest User account?

  2. Generally to you have any pastboard extensions installed, try disabling them and see if that fixes things.

  3. This thread mentions that “Updated command line tools to 10.10 and latest Xcode” fixed the problem for them.


I use Alfred’s clipboard history, but turning Alfred off didn’t fix the issue. In this case, restarting the machine fixed it. I’ve had this happen 2 or 3 other times, always with FoldingText (maybe I’m just not trying to copy in other apps that use a webview? I don’t know…) My Xcode/command line tools are already the latest version.