FoldingText 2.1.1 Dev Release

Hi Everyone!

We’ve just uploaded FoldingText 2.1.1 (Dev) and it comes with a lot of major and minor bug fixes.

The biggest one that we hope you notice is going to be FoldingText’s scrolling and editing performance. If you notice anything different or weird going on, please leave a comment or even better create an issue here.

Other noticeable change includes the new Calc mode. It now works within lists and ignores list syntax. We’ve also disabled syntax hiding for the calc mode, so it no longer shows 2 *34* 5 as 2 34 5

Although we have tried to get to the bottom of the todo item checkboxes being shown as sheet music glyps. If this release still doesn’t resolve your issue, please uninstall (and re-install) the Source Code Pro front on your systems. We’ve bundled the latest release of the font in FoldingText, and updating your installed fonts to match this version should help with this issue.

We’ll try to get this release to stores soon, but for the meanwhile, enjoy! :smile:

All feedback is welcome as always!


One thing I really liked about a recent dev release was that bullets only became checkboxes if they were first-generation children of .todo items, not grandchildren or beyond. I like to leave notes on my todos, indented beneath them, but I can’t bullet them without turning them into checkboxes as well.

Maybe checkboxes could be applied to grandchildren only if the same bullet marker is used? So that if a child node uses a hyphen, and a grandchild node users an asterisk, the asterisk’d node won’t become a checkbox; but grandchildren that also use hyphens would become checkboxes.

  1. Quick question: should the dev build work as a trial even if I have the MAS version installed?

  2. With a non-default font configured through user.less (Helvetica Neue), here’s how a checked checkbox looks like:

With the default font it looks like this:


  1. if i remove my copy of Source Code Pro, the checkbox looks ok.
  2. once I reinstall Source Code Pro, the checkbox goes back to the display above.

That’s a quick update. I can confirm that all addressed bugs in this release are fixed. Keep up the good work!

This is basically a personal preference and one that we reverted because a lot of people didn’t like that .todo mode couldn’t have nested todo lists. It also made sense to have nested todo lists to me.

The problem with matching list markers with their parent’s is that it can get a bit messy, and in my opinion not too scalable. Another method was to only allow - as the todo marker and not + or *, but that also is a bit of a personal preference.

At this time, I would say that nested todo lists are here to stay, and if you’d like to have unordered lists within todo lists, you might want to use a different marker (of course these won’t be recognized by FT as lists) like --, \-, |-, etc.

This is very interesting. Can you paste in the custom .less you have so I can try this out on my machine?

Regarding your Dev mode trial period, I’m not sure about that too much yet. @jessegrosjean can you comment? I would think that since MAS licenses are different from Paddle Licenses, and the dev mode is based on Paddle, it’s not finding your license.

Your thoughts on that sound about right… two different license systems. Though at one point I know I had it working if you if you first launch the Mac App Store version, then (same computer, same account) launch the Paddle version.

That might still work, but I have’t tested.

Though at one point I know I had it working if you if you first launch the Mac App Store version, then (same computer, same account) launch the Paddle version.

Indeed, this dance seems to continue to work.

I’ve left you a private message that includes the user.less.

I saved the dev version in ~/Applications directory and the main FoldingText application in /Applications directory. Even though I explicitly launch the one in my home directory, it launches both copies! Anyway around this? I didn’t want to remove my main copy just in case the dev version had major bugs.

Been noticing some weird FT errors since upgrade. Mostly strange UI stuff, but this morning had moment where I couldn’t enter any tags (pressing “@” produced an error honk, and adding tags through snippet expansion resulted in tags FT didn’t recognise as tags— no default grey text). Not sure what triggers this yet.

For example (see second to last line):

…and an example of how this behaves when I attempt to interact with it:

I’ve restarted FT a few times, and rebooted, but errors keep cropping up. Saving the file in this state failed to write changes; although the file appeared to have saved, it was returned to a previous state when reopened. The only way to recover this particular file was to copy all of the contents to a new file.

Got the following from console:

26/11/2015 09:39:19.710 FoldingText[422]: Failed to load Javascript on start
26/11/2015 09:47:48.034 FoldingText[1215]: BUG in libdispatch client: kevent[EVFILT_MEMORYSTATUS] add: “Operation not supported” - 0x2d
26/11/2015 09:47:48.657 FoldingText[1215]: assertion failed: 15C47a: libxpc.dylib + 63930 [61AB4610-9304-354C-9E9B-D57198AE9866]: 0x89
26/11/2015 09:50:24.343 FoldingText[1375]: BUG in libdispatch client: kevent[EVFILT_MEMORYSTATUS] add: “Operation not supported” - 0x2d
26/11/2015 09:50:25.042 FoldingText[1375]: assertion failed: 15C47a: libxpc.dylib + 63930 [61AB4610-9304-354C-9E9B-D57198AE9866]: 0x89

Thanks! I’ll take a look

How are you starting FT? Opening via double clicking a doc or by opening up the app? Can you send me a screenshot of how that looks like? I don’t understand how two different apps would be started by opening just one :confused:

Your checkboxes seem different. Is there any custom JavaScript you’re loading? Which isn’t available to the update? Can you remove the plugins you have installed and see if the problem goes away?

In my user.less:

   .cm-checkbox-renderwidget {
	input {
		pointer-events: all;
		appearance: checkbox; 
		-webkit-appearance: checkbox;
        vertical-align: 3px;

	input:before {
		content: "";
        vertical-align: 3px;

	input:checked:before {
		content: "";
        vertical-align: 3px;

I removed all my plugins and added them back one by one, hoping I could figure out whether one of them was the cause. No joy. The error I recorded in the screenshot(s) above is no longer affecting the file, but I haven’t yet been able to zero in on what caused the issue in the first place. I’ll keep my eyes open and report further.

My checked checkbox symbol seems to be a musical note - any idea what could be causing that?

Just a flag— I’m still seeing some weird UI errors on occasion, along the lines of my original report. Also, I’ve experienced moments where Jamie Kowalski’s filter plugin errors out (error “honk” when I attempt to invoke it) and the file I’m working in fails to save. Restart sometimes clears the issue, sometimes doesn’t. Haven’t figured out a trigger or pattern yet.

Also: neither schedule nor stopwatch modes are working for me.

If you check the difference between the schedule mode and the system clock (top right), you can see that the schedule is stuck on the second item. Stopwatch mode doesn’t seem to be rendering correctly.

I could have sworn Schedule mode was fixed in a previous update?

I’m not sure, both of them seem to be working OK for me in the latest 2.1.1 … maybe try removing plugins and custom styles and see if that makes a difference? (Or better/easier maybe just try using FoldingText from guest user account as simple starting test).