FoldingText for Atom 0.6.0

  • Added join items command.
  • Added duplicate items command.
  • Added support for “move” drag and drop effect between outlines.
  • Added support for “link” drag and drop effect. To create links hold down the control key when dragging and dropping on OS X. A hyperlink is inserted linking back to the dragged item. You can link to other parts of the current outline, or to other outlines.
  • Removed formatting popup, moved those items into context menu.

Here’s how to use Drag & Drop.

Here are the Installation instructions for FoldingText for Atom.

No, leads to nowhere. A file is created with the name of the link and no content.

This does seem to work on my computer. Trying to think of what might be wrong…

  1. Are you on OS X or some other system (I’m testing on OS X)

  2. Just had another thought , the document containing the item that you are dragging must be saved for this to work. I’ll add a warning about that case.

Do either of those explain the problem?

Working well here … are you dragging and dropping to a point within an FTML file ?

( these are links between lines, either within one document, or between documents, I wonder if you are talking about dragging from a line to the Finder ?)

Yes, I try to link within a file. I think it has nothing to do with FT - in an older version of Atom “Copy Path” worked well. Sometimes I get a Console messge: “kernel[0]: Sandbox: Atom(2916) System Policy: deny file-write-unlink … Saved Application State/com.github.atom.savedState/restorecount.plist”

I am using v 0.6.0 on Atom 0.209.0 on OS X 10.9.5

When my cursor is on a line and I hit Escape, the line is no longer highlighted. I cannot tell where I am in the outline unless I am in editing mode.

If you are in “text editing” mode (i.e. you see a vertical text caret) and you hit escape it will take you to “outline mode” where the entire line gets selected and the text caret disappears. If you then hit escape again it will move focus to the search field… is that what’s happening?

Atom v0.6.0 on Atom 0.209.0 on OS X 10.10.3

  1. It doesn’t work in folders with a space in the name. If I have ‘file1’ in ‘test folder’ and link within the file itself atom opens ‘test%20folder/file1’.

2.Otherwise i can link within a file, but not across. This just becomes a copy of the node (and children). If I made a link within a file i can then successfully copy that link to another outline.

No. I can confirm that after the first hit of Escape the app is in outline mode because I can add a status to a line, but the line used to be highlighted last time I used the app (.4.x) and now it’s not, so I can’t see that it’s in outline mode or which line is active.

Thanks, I’m now tracking that here:

When trying to create links “across” files are you working with multiple Atom windows, or a single window with multiple panes? It should work in a single window, but across windows has this problem:

Do you have any custom styles setup that might be the problem? Maybe try this:

  1. Atom > Open Your Stylesheet

  2. Paste in this style:

.ft-item-selected {
  > .ft-branch {
    > .ft-item-content {
      background-color: red !important;

Then it should be that you see a red background behind selected items when in outline mode… does that seem to be the case?

I updated my css, restarted atom and I do see a red background behind selected items. Is there a particular hex code for the background that you use for selected lines?

By default I’m using a LESS variable that Atom should be defining: @syntax-selection-color. What Atom theme are you using?

One Dark (for both ui and syntax)

I didn’t actually know about the panes. I did use separate atom windows indeed.
After renaming the folder, I just tested opening the files; everything worked as expected.

And it doesn’t like brackets in filenames: “[test]one” etc.

I am very happy with the linking capabilities, because it opens up a workflow I use FT2 and nvALT.

I am imagining a kind of ‘wiki-package’ that would play well with the ‘md-package’ that would use a keybinding (like cmd/cntrl+shift+l) to link to another file much like the [[]] syntax does in nv(ALT/PY). in nvALT suggestions would be offered based on other notes. Even if that would not be incorporated, having the keybinding would be very useful for my use case. Another feature would be if it would be able to be translatable to markdown down the road like this answer on stack overflow. Meaning that I’d be able to link to ‘myFile#secondSection’. However this might be difficult to implement if people would like to refer to a deeper layer.

Here’s what I see with the One Dark UI and Syntax themes:

Text mode with “n” selected:

Then I hit Escape and see:

Can you try duplicating that scenario and tell me if you notice any differences. In particular do you see the “n” highlighted in the same way when you have it selected in text mode?

Also, what happens if you take away the !important part of the red styling that I gave you so you just have:

.ft-item-selected {
  > .ft-branch {
    > .ft-item-content {
      background-color: red;

Still see red highlight?

If I select a letter in text mode, I see it in that grey color. When I hit escape the background turns red. When I remove !important from the css it is still red.

How about when you remove all the rules that I told you to put into your custom stylesheet… still see no background in that case?