Normal Copy Doesn't Work

Whenever I try to copy text from a document, it doesn’t seem to work. However, Copy as Rich Text and Copy as HTML both do. I’ve tried both command-c as well a selecting Copy from the app menu. Has anyone else seen this before?

Normal copy seems to work for me…

What happens if you choose the menu item with the mouse instead of with keyboard shortcut. Does that work?


That’s what I mean by selecting Copy from the app menu. Here’s a video of it happening:

Sorry… I didn’t read that closely enough. Hum…

  1. Do you have any plugins installed? If so please try to uninstall them and see if that fixes.

  2. If you Help > Software Development Kit and then click “Run Editor” and then click the “Inspector” toolbar item… then try copy paste. Do you see any errors reported in the inspector console?

  3. Can anyone else reproduce this?

Hi Jesse, I’m experiencing the same issue.

It persists with no plugins installed. The Inspector console doesn’t report any errors when it occurs.

More info:

  1. When I press ⌘C, ⌘V, or ⌘X, the “Edit” menu bar item does flash as normal.

  2. I can copy text from other applications and paste it into a FT document successfully.

  3. ⌘X will lift the text out of a FT document; however, it will not paste back in to that FT document or anywhere else in the system.

  4. If I select some text in an FT document and press ⌘V, it “pastes” zero characters, replacing the selected text with no text.

Thank you!

This problem totally disappeared for me today. Same document. Hadn’t updated or even closed FT. Go figure.

When you were seeing the problem did you try to quite and restart the app to fix it? I’m wondering if in your case it was a simple restart that fixed it or some bigger change.

I did; I had to restart the app to disable my plugins.