Reminder Tools – some scripts & a plugin for linking FoldingText to items

Linking FoldingText ⇄ – notes on some scripts and a plugin

How are you calling the clock-producing shell script? I can’t see that it is happening from inside the applescript. Do you go in an manually add the correct clock?

Also, things only work without pulling the date data. I am getting an applescript error telling me it can’t get the alarmlist from recnode. It comes from line 299 in the script.

Hi, that may be a version control issue which arose yesterday. I’ve pushed later version of the Reminders and SmallTime plugins, and an update to one of the applescripts.

I think you should find, if you download the later versions, that the clock face updates automatically. Let me know if you still have any problems.

That took care of it. Pretty cool idea. Thanks for making this. I am getting more and more exciting about where FT2 is going.

I’m still getting errors with the most current version. After I set an alarm tag on an item, e.g. @alarm(2014-08-07 15:00), then run the FTMake script, I don’t get a clock face, I get a red question mark as the link. Also, the reminder in has no due date. So, it seems the date isn’t being recognized?

On line 30 of the script you just need to indicate which tag name you are using for your Reminders alert dates.

I think you are using @alarm and the script is looking out for @alert

(I think I probably changed the default at some point to my own use of @alert )

You’re right. I still had some text expander snippets from the older “tree-tools” repository that used “alarm” instead of “alert.” Hadn’t seen that the tag had changed in the new script.

Yes, I think Jesse has (again) made something extraordinary here.

I try to run CopyReminderAsTaskPaperOrFT.scpt and CopyReminderAsLink.scpt, but get an error saying:

error “System Events got an error: Can’t get window 1 of application process “Day One Reminders”. Invalid index.” number -1719 from window 1 of application process “Day One Reminders”

Is there anything wrong?

Can’t get window 1 of application process “Day One Reminders”.

好球!That clash with Day One Reminders should be fixed, I think,
in ver 0.15 of those scripts.

Download repository zip

It works now, thank You! Your fix comes so fast.

If I set system language to Chinese rather than English, there’s a little bug if I try to transfer item into FT text: uses 今天/明天 instead of today/tomorrow. The smalltime.ftplugin does’t recognize these two Chinese work, I think.

Could you tell me a bit more about what you are doing and what is happening ?

Which script are you using ?
And what error are you getting ?

(I have only written the informal and relative date logic in English - it could certainly be done in Chinese, and the source code is there if you want to experiment, but my intention was just to 先凑合 – write something small and simple that would do for the moment)

When I run CopyReminderAsTaskPaperOrFT.scpt and CopyReminderAsLink.scpt when the items in are between now and tomorrow, it returns only " " but no other errors. If the items in are beyond tomorrow, it works as expected. I believe that’s because of these two Chinese words.

In the absence of a built-in Copy As Link for, these scripts rely on a low-level reading of the strings in the UI elements, which makes localisation (as always) just slightly more tricky than it really should be.

You are welcome, however, to try version .016 of the scripts, which make different assumptions about yesterday|today|tomorrow strings (and about the shape of dates) if they detect a user locale beginning with zh, as in zh_CN.

(You can test your basic locale settings in applescript by running the one-line script:

display alert ((user locale of (system info)) as Unicode text)


Repository zip

It works for me now, thanks! These tools are so powerful and magic, I’m considering moving my GTD & outlining workflows to FT if the query tools across files are more user-freindly.

Love this integration! Thanks for sharing.

I’ve am able to run all the scripts except for one. The FTMakeOrUpdateReminder generates the following error:

"Can’t get uuid of "Error: Module name \“T\” has not been loaded yet for context: _

I’m have OS 10.9.4 loaded using FT 2.1 Dev (741). I’m new to this stuff so It’s probably something simple I’m missing.

Good ! I’m glad these things are proving useful.

At the bottom of the installation notes it mentions the need to install a couple of plugins which enable the scripts to work.

Are they both showing as properly installed in the FT plugins list ?

Thanks for the quick response.

Yes, both are installed and are version 1.3.0

Not sure what is stopping one of those two plugins from loading properly on your system.

Might be worth downloading them again, but I’m planning to push updates early next week, so you could wait for those if you like.

The other thing, to get a more detailed sense of where the problem is, would be to run Help > SDK > Editor with Debugging > All exceptions clicked and blue. You should then get fuller error messages and perhaps a line number, when you try to use the script.