When will printing work correctly?

I just realized that printing is broken in FoldingText. Only the first page and a trailing blank page gets printed. It was working better earlier in the testing process, but I something broke. I’m looking to fix it now.

actually I was wondering whether you could give us some piece of information or not.
Yet a timeline would be plain great, but well.
And yes, I do print a lot, but to produce PDF-files…
Many thanks indeed

Printing should be working better in the latest dev version. Its still not perfect, sometimes a single line of text gets divided between pages. But generally it should be fine for getting a hard copy. For final output FoldingText isn’t the right tool anyway, something like Marked is what you need.

…cheers, but FT is just wonderful for what I do most, that is writing and note-taking, as well as planning.
Marked does look quite exciting, but I currently only generate some PDFs only in order to later review what I have been writing using some iOS device,
But when do you plan to release an update through the App Store?
Thanks again

@fransik I just released the 2.0.2 update this morning. You can get it through FoldingText > Check for Update, or the Mac App Store update mechanism if you are using the Mac App Store version.

Jesse, I have version 2.0.2, but as you said printed lines at the bottom are split. See below.

Folding Text is such a great tool, it’s a shame I can’t use it in my professional reports. (I do have Marked 2, but it’s not really appropriate for presentation. Please, the print function/layout really needs a fix. Thanks for your consideration.

Unfortunately I could never find a solution to this. For printing I’m just handing off to WebKit’s WebView to perform the actual print. I’ve looked around for different ways to avoid the problem, but nothing’s worked so far.

Printing is not working for me at all in FoldingText. One thing I was hoping was that it would print WYSIWYG; that is, folded text would not appear in the printout. But I can’t test for this at all since it won’t print. :confused:

Print doesn’t do anything for me at all either. :frowning: