FoldingText 2.1 Dev (741)

  • Added .calc mode
  • Added .stopwatch mode
  • Renamed .time mode to .schedule
  • Added Focus Out menu item
  • Added support for smart pairs: (), {}, etc.
  • Convert to list better handles level 0 body text
  • Control-Return inserts line separator
  • Added bottom padding and typewriter scrolling options to code. Not yet exposed in UI
  • Hold down Command when clicking on tag to include tag descendants in results
  • Space after snippet text will now expand the snippet. Use Option-Space to escape that behavior
  • Added logging of path used to check licensing
  • Don’t show “Show License” menu item if not activated
  • Fixed crash when node path contained empty string //""
  • Try harder to open a file with an unknown plain text encoding
  • Fixed problem where .schedule would run after closing document
  • Fold nodes command updated handle empty node at top of selection case better
  • Added MultiMarkdown processor for Copy as (RTF, HTML, LaTex) conversions. End results is the Edit > Copy as options all work much better now

This is a rather messy dev release. Quit a few in progress things, but I’m going to be gone for the next week and wanted to get something out. Anyway give it all a try and let me know what problems you run into. I’ll be back next week.

I’m really getting into this app. I love it.

Should that read “Renamed .timer mode to .schedule”? I wouldn’t mention it but I noticed the same typo is in Folding Text’s Help Menu → Release Notes document.

Nice release! Been meaning to ask about a calculator mode— good to see. You’ve also implemented the requirement to state .todo mode for sub-task items? Thus far, it hasn’t introduced as much friction as I thought it might…

Stopwatch mode: “play” button and total runtime are persistent to the left of the line item. Not too much of an issue on a single step timing, but if you stop and restart, the overlay’s more of an issue.

Hey Jesse,

I love the calc mode! I’d been thinking of implementing something like this myself for a while, but I’m glad you’ve added it first. It’s extremely capable, and adds another entire use-case to the app.

Something I’m seeing in this release that I think is a bug (I’m not sure if it started in this release or earlier): within a mode, grandchildren are not recognized, i.e.:

# List.todo

- First level
    - Second level

The “Second level” item is not styled as a to-do item.

Hey Jamie— not a bug; I think Jesse missed it in the feature update list. See:

In short, you now need to add .todo for an item with “actionable” children, otherwise they’re now simple list items by default.

Request: any chance of dropping single quotes from smart pairing?

Oh, I see; that’s a significant change. I’ve added a note to the thread you linked.

Yep, that should be fixed. Single quotes used as apostrophes get an unwanted pair! I wonder if there could be a heuristic: if the preceding character is alphanumeric, don’t add the pair.

Is it just me, or does the .calc mode not work correctly? As far as I can tell, you can only get the calculation to run if you work on a bulleted line (see second example in image below); but the calculation acts as if the bullet represented a negative sign. So, for example, 1/2 = –0.5, because technically you have “– 1/2”

The .calc mode only applies to lines that are descendants. Make trial.calc into a top-level heading (i.e. add a # at the beginning), and all lines below it will be in calc mode:

# trial.calc

strange problem with 2.1(741)… tried to build a new node path (/inbox//@today). Doesn’t work. I’m new to FoldingText, so I could be doing something incorrect. Apologies if my comment is too basic for this forum.

I just download v2.0 and tried the same nodepath and it works. So, there is some sort of problem with 2.1(741). Below is the file.



  • item1
  • item2
    • item2a
    • item2b
  • item3 @done
  • item4 @today

The sample you are showing wouldn’t get a match from the path you are showing, because the tag is not a descendant of a top level node (zero indent) named Inbox

But perhaps there was a truncation in the pasting and posting ?

+1 for not including apostrophes in smart pairing.

And a request – maybe others can chime in with whether it is a useful one or not – to tab out of a smart pair, i.e. if I start writing (something|) where the pipe is my cursor, I have to get past the closing bracket to continue typing, and for me the most natural way to do so would be to tab past it.

tab out: sounds useful to me.

One issue I’ve had with quoting things is that I tend to paste some text into a document and then try to put backticks around it. I’ll put the first backtick at the beginning, and that works fine, but when I put the one at the end, it always puts two (one before and one after the caret). If I try to delete the backtick to the left of the caret, it deletes both! I end up having to do a little keyboard dance, backtick-right-delete. Not ideal.

IDEALLY, I’d like to select the text, press backtick (or any quote) and have it put the quote characters around the selection.

SUPER IDEALLY, if I select something that’s already quoted at both ends, and I type a different quote, it should change the quote in the selection.

well, I’m really baffled… I went back to FT v. 2.0 for a few days and had a terrific experience using node paths to fold text. Really cool.

Then, after sharpening my skills (or so, I thought), I went back to the Dev version and tried this:


# test
- item1
- item2
	- item2a
	- item2b
- item3 @done
- item4 @today

The label link is x-foldingtext://documents/current?nodepath=%2F%2F%40today which was created by selecting the text //@today and using link node path from run command.

I click on label, and nothing happens. No folding.

What am I missing? Has the syntax for node paths changed in the Dev version?

Thanks for any guidance you can provide. For now, I’m just going to go back to FT v. 2.0 although I’d like to play with some of the cool features coming on in the Dev version.

@midas Your node path is correct… none of that has changed. But you found a bug in the dev version! The code for clicking on node path links is broken in the current release, I’ve just fixed it for the next.

And while you’re waiting for the link fix, Jamie Kowalski’s Filter plugin is still working fine in Dev 741: