Plug-ins have stopped working in Taskpaper Dev 129

I have been using Taskpaper dev 129 build since it was released and used a few plug-ins (for example filter/jmk-panel from Jaime) with no issues. Recently when I opened taskpaper it would hang for 5 seconds and then open up an untitled document but does not show a cursor (no access to the window). Trying to open a document results in the same untitled window. Opening up SDK editor also does not allow entering text.

After several tries I final deleted all of the plug-ins and it is working again. To be safe I followed your “hello world” plug-in tutorial again to see if at least that would work. The same issue popped up. Deleted the plug-in and it’s working again.

I’ve tried to go thru the debugger to track down the issue but can’t seem to find anything within my scope of knowledge to fix.

Understand this is still beta but it’s strange that it was working fine for several months and then all of sudden stopped working. And the fact that the simple hello world is not working. I also tried deleting the app including supporting files and re-download. Still no plug-ins allow.

Any help would be appreciated. Let me know if there are any log files that can help you debug.


129 seems to be working here …

Might be worth looking for specific error messages with:

 Help > Software Development Kit > Editor > Inspector > Debugger > All Exceptions

There was nothing under All Exceptions. Found this looking at the console log in the SDK Editor window:

Error requiring plugin paths
line: 3
message: “‘undefined’ is not an object (evaluating ‘Extensions.addInit’)”
requireMap: Object
requireModules: Array[1]
requireType: “define”
sourceURL: “file:///Users/ryanl/Library/Containers/com.foldingtext.TaskPaper/Data/Library/Application%20Support/TaskPaper/Plug-Ins/Today.ftplugin/main.js?430790815.000000”
stack: “file:///Users/ryanl/Library/Containers/com.foldingtext.TaskPaper/Data/Library/Application%20Support/TaskPaper/Plug-Ins/Today.ftplugin/main.js?430790815.000000:3:15↵execCb@file:///Applications/↵check@file:///Applications/↵enable@file:///Applications/↵init@file:///Applications/↵callGetModule@file:///Applications/↵completeLoad@file:///Applications/↵onScriptLoad@file:///Applications/”
proto: Error

Any luck if you restart without the today plugin in the Plugins folder ?

yes, as I mentioned in the original post, TP works fine when I remove all plugins. I tried to then load the simple “Hello Plugin” copy and pasting directly from Jessie’s instruction. Immediately it will freeze the program when loading.

I wonder if one plugin required by another has been deleted ?

Not sure what is amiss there – here is the set of plugins which I’m using, and I just created a test.ftplugin by copy-pasting the “hello world!” tutorial code, which also seems to be working.

It may be worth reinstalling the 129 beta if you can, and bringing the .ftplugin folders back in one by one until you hit something like a dependency issue.


PS, for example, if you’re using any of mine, relative dates and reminder tools both depend on smalltime

(This kind of thing will be much easier to track in the new build, of course, which I imagine will be getting the same plugin manager as the current FT releases - much easier then to check which plugin needs attention and why)


PPS I wonder if a line which should read:

Extensions.add('com.foldingtext.editor.init', function (editor) {

has somehow got changed to


Or whether that is a residue, in an older plugin, of an earlier API ?

Essentially something is trying to call an .addInit method of the Extensions object, which doesn’t actually export a function of that name.

So I removed my current 129 install and all associated support files I could find. Reinstalled a new version of 129 and app works fine with no plug-ins added.

I then created the hello.ftplugin with copy of the main.js code Jessie provided and it is now working.

Proceeded to add jmk_panel.ftplugin and everything still working.

Finally added filter.ftplugin and it freezes just like before. Definitely something going on with filter plugin but I can’t seem to debug it further.

Good ! Sounds like you’re on track there.

I’ve you haven’t already, I would download a fresh copy of the filter.ftplugin and see if it still happens. It’s possible that Jamie has updated it to keep abreast of of FT2, and that there is some backward incompatibility with TP3.

Probably worth asking him for advice.


This is likely a problem. addInit is a new shortcut API for Extensions.add('com.foldingtext.editor.init',. This new API is available in the latest FoldingText, but it’s not available in the latest TaskPaper dev version.

Got it – that makes sense.

( @ryanlaner I clearly have a copy of the older version here, so let me know if you need it )

Thanks guys. I worked my way back thru Jamie’s git commits and was able to enable the filter plugin using SHA1 commit of 5846fe2. Everything is working smooth again.