"Sorry - Unspecified error" when activating new license

Hi, I just (finally) upgraded to Catalina, and ran into problems when trying to activate FoldingText within the new OS, resulting in the error message: “Sorry - Unspecified error”.

Initially I re-bought the software because I’d misplaced the license key, and received this error when I submitted it in the activation pop-up window.

Once I saw that the key came in an email from paddle.com rather than directly from hogbaysoftware, I searched my old emails for my original license key, found it, and got the same error when I submitted that.

Since that didn’t work, I then tried uninstalling & re-installing FoldingText, being thorough and deleting every system file related to it.

Unfortunately it looks like I was too thorough, as this only made things worse! Now the FoldingText app insists that my 7 day trial period is over, so I’m locked out of using the app until I can resolve this.

Any suggestions would be most appreciated, as I’d like to keep using the app!

Update: I was able to seek out and restore the system files associated with FoldingText from a daily backup I’d done. Now I have 6 days remaining in the trial period until it expires.

I’m still getting a very persistent error message: “Sorry - Unspecified error” whenever I try to register the software, both with the newer license key and also the old one. I tried this registration step before restoring the files and also afterwards, but in every case this unspecified error is very persistently blocking me from registering this software.

Sorry for my slow reply, and glad you got a reset working at least.

I’m not sure why that’s happening. I’ve sold FoldingText and will work with the new owner to try to get this fixed. You’ll be able to find the latest info in the new FoldingText forums:


Thanks for your reply, and thanks also for the link to the new forums.
I’m glad you’re both working on this!!

It looks like there is now a fix for this problem:

If you are a FoldingText user and have been having license issues it looks like FoldingText’s new owner has released a fix: https://support.doubledogsoftware.com/t/activate-license-error/37/18