Tes consumed all of my disk space

I was trying to save an edited photo in Photoshop Elements and it kept complaining that there was no disk space. The Finder confirmed that I was down to 1.1 GB. I ran Grand Perspective to try to determine what was going on, and I found that Tes had gobbled up 145 GB of disk space in ~/Library/Application Support/Tes. See uploaded screenshot.

Is there anything I can do to help debug this?

Which version of Tes are you using? Can you delete the clip.

The latest version. I just updated within the last two days. Right now it’s hung when I tried to access it. This version has serious problems.

It wasn’t a 145GB clip - it was was many files in the Application Support directory. In the GrandPerspective screenshot that I uploaded, every little box inside the big green box was one of the nearly 45K files in the Application Support dircectory. I deleted all of them.

After killing it and restarting, I was able to check the version - 1.0.4. But when I ran Update, the attached screen shot of the dialog showed up. It says that the latest version is, but I’m running 1.0.4.

It’s also currently using ~15% of CPU continously.

Something isn’t right.

Did this happen after you upgraded 1.0.4?
Did you copy a large file before this happened?


If you have iCloud sync turned on all of your clips are back-up on your iCloud, which is probably the easiest. You could turn it on if it isn’t on to sync your clips.

  • Export your clips in preferences, for extra security.
  • Quit Tes
  • Create a directory in ~/Library/Application Support/Tes to save the current database.
  • Copy the TesData* files to the new directory
  • Delete the TesData* files and the app directory
  • Restart Tes. your resync your data from iCloud, or import your clips from Preferences → General

It happened after upgrading. I have been working on cleaning up some scanned photos in Photoshop Elements, which sometimes involves copying larger images.

When it consumed all my disk space, I didn’t know what was going on so I rebooted my Mac. I ran GrandPerspective after it rebooted to see what was happening with my disk space.

When I saw that there were 145GB of files in the Tes AS folder, I quit it and started this topic. But the next night I started it again.

I did some more image copying work with PE, and that’s when I found that Tes would not respond, and I had to force-quit it manually.

I’ll leaving it turned on today to see how it responds in idle state, and I’ll check it after work to see if it’s still responsive.

I deleted the contents of the ~/Library/Application Support/Tes when I found that Tes was using all my disk the other day. I’ll start experimenting with this again and see if I can reproduce the condition.

I will be busy this weekend, but I’ll try again when I can.

There is an option in Tes for setting a max file size to copy. When you can check that and make sure it is a reasonable size so Tes won’t copy large files.


Tes was always set up to sync with iCloud.

Weekend updates:
Friday morning I changed the settings to ignore files greater than 10 MB. Tes was running all day when I was at work, and it was behaving properly when I got home.

Then I opened an image in Photoshop Elements, selected some portions of the image, and copied it around 4-5 times. I didn’t work with the images, but left my Mac alone for the night.

Saturday morning it seemed okay, but I was doing some copying and pasting of text for a list (ten clips total), and eventually Tes hung again. Activity Monitor showed that Tes was consuming ~37% CPU, and I had to force-quit it.

I was using CotEditor to put together the list, and it hung as well. I wasn’t using CotEditor when the other problems occurred.

I deleted the Tes directory and restarted it.

I was gone on Sunday. Monday morning I checked it, and Tes is unresponsive again, after clipping one short sentence. Activity Monitor shows that it’s using ~18% CPU. Killed and restarted Tes.

Tuesday evening, I copied some things (two phone numbers and a paragraph of text), and Tes responds fine from the menubar. It’s consuming ~30% CPU.

I was able to reproduce the issue! I was using Photoshop Elements’ spot heal tool a lot while editing a photo, after around 45 minutes, my Mac displayed a “disk getting full” message. I checked the Tes App Support folder, and the ckAssetFiles folder had > 14K files at 116GB. Oddly enough, the Tes menubar app is not hung this time, and it only had the original copy of the photo that I’m working on, and the copied image was 7MB. See attached.

If you have a version with logging or debugging that would help you with this, I am willing to try it for you. Otherwise, if you have Photoshop Elements, like I said, I was just using the spot heal on the photo many, many times. It seems as if Tes and PE’s history functionality are clashing somehow.

Thank you so much for the detailed feedback. I’m trying to understand why CoreData is downloading these files now. When it didn’t before 1.0.5. I also found a bug in 1.0.5 where the max clip size is overwritten when you restart Tes. I have fixed the issue of the max clip size. I was going to release the fix, I thought I had fixed the issue with CoreData syncing the files. If you don’t need iCloud syncing turning it off may resolve that issue.

That is a great picture of your grandparents. I hope to have the new version out today, if I can figure out why the files keep on getting downloaded. In my testing it was the same file over and over again.


Tes version 1.0.6 resolves this issue. If you have yet use Check For Update to download the latest version.


FYI: I had the same problem/issue and 1.0.6 seemed to fix it! Thanks!

I installed 1.0.6 and did a bunch of Photoshop Elements editing again, and the problem seems to be fixed.

Tes still uses around 17% CPU on average, but other than that it’s behaving nicely.

That is interesting that Tes is using that much CPU.

Are you using iCloud sync?


I was using iCloud sync. When I just checked the CPU usage it was 50+%. I unchecked iCloud syncing, but the usage didn’t change. Then I closed and re-opened Tes, and now it’s minimal - 0% usage. That’s with syncing enabled.

I’ll keep an eye on it, and if it climbs up again, I’ll try some things (clipping photos, stopping/starting Tes), both with syncing enabled and disabled.

Well, Tes is not seemingly eating up my disk space, but it is very busy:

Hmm, above was my attempt to upload the Activity Monitor images showing:

  1. Tes has written around 670GB to disk!!! Thing is, where is it writing this? My disk is only 500GB! The Tes Application Support directory is only:

-$ du -sh ~/Library/Application\ Support/Tes
81M /Users/xxxxxx/Library/Application Support/Tes

  1. Tes is using 90% CPU!

Finder shows that I have 108GB free, and it is not growing.

  1. I do have iCloud sycning on, so maybe that is it?

This needs to be fixed as it seems to be working hard and wasting battery, etc…

Let me know if I can supply any other data to help you investigate…

I just finished an extended Photoshop Elements session with lots of spot heals, cuts, and pastes. Cloud sync enabled. Since restarting Tes 1.0.6 after seeing it use high CPU last time, CPU usage is minimal again.

That is interesting about the disk space. Maybe it’s temporary from iCloud syncing.

@redanzl Did the following and it solved his issue. “I was using iCloud sync. When I just checked the CPU usage it was 50+%. I unchecked iCloud syncing, but the usage didn’t change. Then I closed and re-opened Tes, and now it’s minimal - 0% usage. That’s with syncing enabled.”

I have seen where iCloud will do this for some reason. if you could give the above a try and let me know. I will look into the disk writing in the meantime .

Thanks for the detailed report.

Thanks @croy, that procedure has worked so far; but it has only been about 1 day so far.

Any luck on the bizarre disk writing puzzle?

I updated to Tes 1.0.7 and the disk writing and high CPU came back.

However, as before, once I followed the procedure @redanzi described above, it seems perfectly fine again.